1. EIGRP의 비용 계산식

Cost = [ k1 * Bandwidth + (k2 * Bandwidth)/(256-Load) + K3 * Delay ] * [ k5 / (Reliability + K4) ]
(k1, k3는 기본값이 1이고, k2, k4, k5는 기본값이 0임)

이때, K5=0으로 하면 신뢰도를 고려하지 않겠다는 뜻으로 비용은 아래와 같습니다.

Cost = k1 * Bandwidth + (k2 * Bandwidth)/(256-Load) + K3 * Delay

- 대역폭(Bandwidth)의 계산방법은

Bandwidth = 10^7 / line_bandwidth(kbps)

- 지연(Delay)의 계산방법은

Delay = line_delay(micro-second) / 10

따라서 k의 변수를 모두 기본값으로 셋팅하는 경우

Cost = Bandwidth + Delay
Cost = 10^7 / line_bandwidth(kbps) + line_delay(micro-second) / 10

가 됩니다.


2. EIGRP 라우팅 프로토콜 설정

#conf t
(config)#router eigrp 100
(config-router)#network 10.1.1.0 0.0.0.255
(config-router)#variance 3                           
- 여러개의 경로를 이용하는 옵션으로 3으로 설정하면 경로중 최소값의 3배 이하인 경로는 모두 라우팅테이블에 등록되어 라우팅이 가능하도록 해줍니다.
(config-router)#traffic-share {balance | min} 
- 트래픽 분산옵션으로 Balance는 비용값에 따라 분배하고, Min은 최소비용경로만 사용합니다.
(config-router)#no auto-summary
- Eigrp는 기본으로 클래스단위의 주소형태를 사용하므로 Classless 네트워크를 사용하시려면 반드이 이 옵션을 해주셔야 합니다.
(config-router)#ip summary-address eigrp 100 10.1.0.0 255.255.0.0
- 수동으로 라우팅을 요약하는 설정입니다.
A: I don’t know how much you know about cars, but I just learned a lot the hard way.
B: Having some mechanical difficulties, are you? Nothing’s ever cheap with car repairs.
A: *** 쉬운 일은 아니죠. *** I practically had to give up my first born!
B: I’ve found maintenance is cheaper in the long run if you do regular upkeep. 
 
 
A:당신이 차에 대해서 얼마나 알고 있는지 모르겠지만 난 어려운 경험을 통해 차에 대해서 많이 알게됐어요.
B:기계적인 문제가 생겼던 거군요.그쵸? 자동차 수리비가 결코 싸진 않잖아요.
A:You ain’t whistling Dixie! 내 인생의 보물 1호를 포기해야 했으니까요.
B:정기적인 점검하면 결국 유지비가 덜 들게 되지요.

[Additional Expressions]
* I don’t know how much you know – I don’t know what you know / I’m not sure if you know
* about – regarding / when it comes to / concerning
* cars – motor vehicles / automobiles
* I just learned a lot – I just got a lesson / I recently found out
* the hard way – through tough experience / by way of personal experience
* mechanical difficulties – car problems / engine trouble
* Nothing’s ever cheap with car repairs. – Fixing cars is always expensive
* You ain’t whistling Dixie! – You’re not lying! / That is the truth! / That’s an understatement!
* practically - almost
* give up my first born – surrender my kid / sell my children / sell my house
* I’ve found – In my experience / I’ve discovered
* maintenance is cheaper in the long run – over time, maintenance costs less
* do regular upkeep – keep up on things / take care of the day-to-day things
 

A: I fell for some movie promotion propaganda and checked out a new flick.
B: Did it measure up to your expectations? Often the promo clips we see are the best parts.
A: It was a complete let down. *** 내 인생의 한 시간 반을 가져가 버렸어. *** that I’ll never get back.
B: Yikes! That bad, huh? Look on the bright side. At least you ate a tub of popcorn.
 
 
A:영화의 허위광고에 속아서, 새로 개봉한 영화 한편을 봤어.
B:기대만큼 좋았니? 종종 예고편에서 본 장면들이 제일 재미있잖아.
A:완전 실망이었어. They took an hour and a half of my life 다시는 되돌릴 수 없는
B:끔찍해! 정말 재미없었구나. 그렇지? 좋게 생각해. 최소한 팝콘이라도 먹고 왔다고 말이야.

[Additional Expressions]
* fell for – went in for / got suckered in by / got taken by / got fooled by
* movie promotion propaganda – movie ads / new film promos
* checked out – went to see / saw / watched
* flick – movie / film
* measure up to – meet / come up to / equal
* your expectations – what you expected / what you had hoped it would be
* Often – Most of the time / Oft times
* the promo clips – the short pieces / the mini bites
* the best parts – the highlights
* It was a complete let down. – It totally flopped. / I hated it. / It was awful.
* They took an hour and a half of my life – They wasted my time / They stole part of my life
* Yikes! – Wow! / Ouch! / Oh no!
* That bad, huh? – Was it really that bad? / Is that how terrible it was?
* Look on the bright side. – Think of the positive side. / There is one good point.
* a tub – a bucket / a big container
 

A: I bit my tongue. Now everything I eat sends a lightning bolt right through me.
B: Suck on an ice cube for a while. It’ll numb it up good for you.
A: I gave that a go, but it just hurt the roof of my mouth. Any other bright ideas?
B: Yes. Zip your lip and give it a rest.
    *** 금방 괜찮아져서 말할 수 있을거야. *** 
 
A:혀를 깨물었어. 먹을때마다 전기가 찌릿찌릿 오는 것 같아
B:얼음을 물고 있어보는 건 어때. 혀가 무뎌지니깐 좀 나을 거야.
A:그렇게 해봤지만 입천장만 까졌어. 다른 좋은 방법 없을까?
B:음. 입을 움직이지 말고 좀 쉬게 나둬 봐. 
   You’ll be gabbing away in no time.

[Additional Expressions]
* everything I eat – any food that I put into my mouth / all the food I eat
* sends a lightning bolt right through me – hurts like you can’t imagine / kills me with pain
* Suck on an ice cube – Put a piece of ice in your mouth / Keep ice in your mouth
* for a while – for a little bit / for some time
* It’ll numb it up good – That will take the feeling out of it / That’ll make it numb
* I gave that a go – I did that / I tried that / That’s what I did
* just – only / simply
* hurt the roof of my mouth – made the top of my mouth sting
* Any other bright ideas? – What else can you think of? / Do you have another suggestion?
* Zip your lip – Keep quiet / Don’t talk / Keep your mouth shut
* give it a rest – rest it / don’t move it
* gabbing away – talking a lot / talking up a storm
* in no time – very soon / in a flash 


- OSPF프로토콜 설정

#conf t
(config)#router ospf process-id
(config-router)#network network-number area

예제)

#conf t
(config)#router ospf 1
(config-router)#network 10.1.1.0 0.0.0.255 area 0

- Frame-relay와 같이 비브로트케스트망에서 OSPF설정

#conf t
(config)#int lo 0
(config-if)#ip address 10.1.10.1 255.255.255.0
(config-if)#ip ospf network point-to-point
(config-if)#exit
(config)#int s0
(config-if)#encapsulation frame-relay
(config-if)#ip address 10.1.1.1 255.255.255.0
(config-if)#no shut
(config-if)#exit
(config)#router ospf 1
(config-router)#network 10.1.0.0 0.0.255.255 area 0
(config-router)#neighbor 10.1.1.2
(config-router)#neighbor 10.1.1.3

'공부방 > 네트워크' 카테고리의 다른 글

라우터에서 DHCP서버 구축하기  (0) 2009.05.22
라우터에서 EIGRP 설정  (0) 2009.05.22
라우터에서 프레임 릴레이 설정  (0) 2009.05.15
라우터에서 PPP모드 사용하기  (0) 2009.05.15
VLAN 설정하기  (0) 2009.05.15
1. 프레임 릴레이 설정

#config t
(config)#int s0
(config-if)#encapsulation frame-relay

- 프레임 릴레이 맵 설정
(config-if)#frame-relay map ip 10.1.1.1 110 broadcast

- 프레임 릴레이 맵 상태 확인
#show frame-relay map

- 프레임 릴레이 PVC 보기
#show frame-relay pvc

2. 프레임 릴레이 다중연결

#config t
(config)#int s0
(config-if)#encapsulation frame-relay
(config-if)#frame-relay map ip 10.1.1.1 610 broadcast
(config-if)#frame-relay map ip 10.1.1.1 620 broadcast

3. 프레임 릴레이에서 Point to  Point 설정
(point-to-point 방식은 하나의 인터페이스에서 하나의 PVC만 지원하므로 PVC내부에서 여러개의 서브 인터페이스를 갖도록 합니다.)

(config-if)#int s0.1 point-to-point
(config-if)#bandwidth 256
(config-if)#ip address 10.1.1.1 255.255.255.0
(config-if)#frame-relay interface-dlci 510

4. 프레임 릴레이에서 Multi Point 설정
(Multi Point 방식은 하나의 인터페이스에서 여러개의 PVC를 지원하고, PVC내에서도 서브인터페이스를 지원합니다.)

(config-if)#ip address 10.1.1.1 255.255.255.0
(config-if)#frame-relay map ip 10.1.1.2 510 broadcast
(config-if)#frame-relay map ip 10.1.1.3 520 broadcast

5. 프레임 릴레이 스위치 설정하기

#conf t
(config)#frame-relay switching
(config)#int s0
(config-if)#encapsulation frame-relay
(config-if)#frame-relay intf-type dce
(config-if)#frame-relay route 510 interface serial 1 610
(config-if)#frame-relay route 520 interface serial 2 620
(config-if)#no shut
(config-if)#exit
(config)#int s1
(config-if)#encapsulation frame-relay
(config-if)#frame-relay intf-type dce
(config-if)#frame-relay route 610 interface serial 0 510
(config-if)#no shut
(config-if)#exit
(config)#int s2
(config-if)#encapsulation frame-relay
(config-if)#frame-relay intf-type dce
(config-if)#frame-relay route 620 interface serial 0 520
(config-if)#no shut
(config-if)#exit

1. 인터페이스 PPP로 변경

#conf t
(config)#int s0
(config-if)#encapsulation ppp

2. PPP사용자 인증 설정

#conf t
(config)#hostname RouterA
(config)#enable secret enapss
(config)#username id password pass
(config)#int s0
(config-if)#ppp authentication { chap | chap pap | pap chap | pap }


1. VLAN 그룹 설정

#vlan database
(vlan)#vtp transparent
(vlan)#vtp domain TEST
(vlan)#vlan 10 name TEST_10
(vlan)#vlan 20 name TEST_20

2. Port별 VLAN 설정

#config term
(cofig)#int fa0/1
(config-if)#switchport mode access
(config-if)#switchport access vlan 10

3. Trunk 포트 설정

#conf t
(config)#int fa0/24
(config-if)#switchport trunk encapsulation isl
(config-if)#switchport mode trunk

-. VTP서버/클라이언트 설정(번외)
(VTP란 스위치로 구성된 네트워크에서 VLAN정보를 생성,전달하는 2계층 프로토콜입니다.)
- 서버모드 스위치(VTP도메인에 모든 VLAN정보를 생성,추가,삭제할 수 있음)
#vlan database
(vlan)#vtp server
(vlan)#exit

- 클라이언트 모드 스위치(서버로부터 수신한 VLAN정보를 변경할 수 없고, 단지 전달만 할 수 있음)
#vlan database
(vlan)#vtp client
(vlan)#exit

- Transparent 모드(서버모드와 동일하나 자신이 만든 VLAN정보를 다른 스위치에 전달하지 않음)
#vlan database
(vlan)#vtp transparent
(vlan)#exit

4. L3스위치에서 VLAN간 라우팅을 위한 가상인터페이스 등록 및 RIP설정

- L3 라우팅 기능 활성화
#config t
(config)#ip routing

- 가상 인터페이스 설정
#conf t
(config)#int vlan 1
(config-if)#ip address 10.1.1.1 255.255.255.0
(config-if)#no shut

(config-if)#int vlan 10
(config-if)#ip address 10.1.10.1 255.255.255.0
(config-if)#no shut
(config-if)#int vlan 20
(config-if)#ip address 10.1.20.1 255.255.255.0
(config-if)#no shut

- RIP설정
#conf t
(config)#router rip
(config-router)#network 10.1.0.0

-. 라우터를 이용해서 VLAN간 라우팅을 할 경우(번외)

#conf t
(config)#int e0
(config-if)#no shutdown
(config-if)int e0.10
(config-subif)#encapsulation isl 10
(config-subif)#ip address 10.1.10.1 255.255.255.0
(config-subif)#int e0.20
(config-subif)#encapsulation isl 20
(config-subif)#ip address 10.1.20.1 255.255.255.0

본 내용은 CISCO사의 제품을 기준으로 설명합니다.

1. 스위치의 IP주소 지정방법

#config terminal
(config)#int vlan 1
(config-if)#ip address 10.1.1.1 255.255.255.0
(config-if)#no shutdown

2. 디폴트게이트웨이

(config)#ip default-gateway 10.1.1.254

3. 스패닝 트리 설정

(config)#spanning-tree vlan 1 root primary

- 확인 -
show spanning-tree vlan 1

'공부방 > 네트워크' 카테고리의 다른 글

라우터에서 EIGRP 설정  (0) 2009.05.22
라우터에서 OSPF 설정  (0) 2009.05.15
라우터에서 프레임 릴레이 설정  (0) 2009.05.15
라우터에서 PPP모드 사용하기  (0) 2009.05.15
VLAN 설정하기  (0) 2009.05.15


A: Last Saturday, I had the good fortune to attend a wedding ceremony. It was touching.
B: Was it a church wedding or was it held at one of those large wedding halls?
A: Neither, actually. The newlyweds went for a more natural setting. They tied the knot at a park.
B: Well, you don’t see that every day. Good on them.
*** 그들은 특별한 걸 원했을거야. *** 
 
A:지난 주 토요일에 다행히도 결혼식에 참석할 수 있었어. 감동적이었어.
B:교회에서 하는 결혼식이었니 아니면 예식장에서 하는 결혼식이었니?
A:둘 다 아니야. 그 새 커플은 더 자연스러운 곳을 원했어. 그래서 공원에서 결혼했어.
B음, 흔한 결혼식은 아니었겠다. 좋았겠다.
They were thinking out of the box.

[Additional Expressions]
* I had the good fortune – I was lucky / I was fortunate
* attend – go to / be present at
* It was touching. – It was a very emotional experience. / I was really moved.
* Was it a church wedding? – Was the wedding in a church?
* held – put on / staged
* Neither – Not either of those
* newlyweds – bride and groom / new couple
* went for – decided on / prepared / chose
* setting – environment / event
* tied the knot – got married / wed each other
* at a park – outdoors / out of doors
* you don’t see that every day – that’s pretty unique / that’s a rather rare event
* Good on them. – Congratulations to them. / That’s great. / Good for them.
* thinking out of the box – being original / doing something most others don’t do 

+ Recent posts